Anyone getting "Something's Gone Wrong Please try again later" as soon as they open their app. Transactions are going through but app is inaccessible

Issue: Anyone getting “Something’s Gone Wrong Please try again later” as soon as they open their app. Transactions are going through but app is inaccessible.
How to reproduce it: ?

OS: iOS 16.3.1

Device: Iphone 13 Pro

App version:3.81.0 (08/03/2023 Update)


Same issue here, and same app version.

iPhone 14 Pro
iOS - 16.3.1
Version - 3.81.0 (new)

Yep I’m getting the same - timing suggests the new release is responsible

Come on Curve - this is getting silly

I’m getting this too, saying passcode is wrong which I know it isn’t. I’ve tried resetting it and still the same

Same here.

iOS: 16.3.1
iPhone 14 Pro
Latest version

But I can use it with an older app version on my second device.
So it looks like the last update is broken.

Same here, same version. Broken since last update.

Hi all,

Apologies for that, we have just added a new build to fix this issue - 3.81.1
Please try this!

3.81.1 works, but had to login again using mobile number and OTP.

1 Like

3.81.1 is not working. Same error on iPhone 14 Pro. “Something’s Gone Wrong Please try again later”

Still not working with 3.81.1. Same problem- “Something’s gone wrong…”

I got update to Iphone 13Pro yesterday and after that cannot accessa app… I did remove app and install again. After that it work ok. Hope this help.

iPhone 13 here on iOS 16.3.1.

Got the error on 3.81.0 this morning and after upgrading to 3.81.1 it’s still there. Phone reboot and app restarts make no difference.

Yes. Delete and reinstall indeed works. Thanks :pray:

Started working sometime this morning - didn’t delete/reinstall OR update app. Nor did it ask for login or any credentials.All OK at present

1 Like

Deleting and installing Curve app did work for me too.

We’re very sorry for this problem. We’re still trying to investigate what is the underlying root cause of the issue. We’ve released an hotfix version this morning, but clearly, it hasn’t worked for everyone.

For people that are having issues still, unfortunately, reinstalling the app should fixed the issue. But, we’re still working behind the scenes to get this fixed properly

1 Like