Bug report 2.18.1

Just updated from 2.7.12 to 2.18.1 and there is 1 very annoying thing. When opening app its presents window with text to enter PIN (as in previous versions), but now instead of showing only numeric part of my android keyboard (i’m using swiftkey) it shows full keyboard (with letters). WHY ???

In previous versions it showed only numeric part of keyboard with nice big size numbers. Now its shows normal full keyboard. There is no need to show full keyboard when PIN is only numbers.

Is this change intentional or bug?
I hope its bug :frowning:

I’m also on 2.18.1 and I don’t have that bug. Plz include your android version so the devs can look into this

Android version is 9.

This is how it looks on 2.18.1:

I contacted support (before news that wirecard got their licence suspended), they suggested to try to re-install curve app.

I am not dare to do it now due to wirecard situation. :zipper_mouth_face:

Also some weirdness I noticed earlier today with 2.18.1:

  1. Sometimes app asks to enter PIN twice.
  2. Sometimes app hangs (no response?) on “enter your passcode” window after entering PIN.
  3. Sometimes app hangs (no response?) on “Curve” screen after entering PIN.

Have you tried with other keyboards? I have the same, but what’s the problem? Just enter the digits?

Sure I can enter. But in previous versions it was 1000 times nicer.

I have not tried other keyboards yet. Switfkey is my favorite. I dont want to try any other ones :slight_smile:

1 Like

Agree, shouldn’t be a need to change keyboard when it worked before. I would imagine it’s being tagged as an alphanumeric rather than numeric field, therefore why it is defaulting to the main keyboard. @nicb do you know if this changed or can be changed back?

It’s not main keybord. If it would be that, it should have letters also, now its still numerical.

It was just the OP said:

But I agree the screenshot looks a bit different. Hopefully the developers can shed light on whether anything has changed. I use fingerprint login anyway so never notice!

Thanks for the feedback.

We did make some updates to the UI of pass codes, some parts of the app were using one UI and some another so they were consolidated. There will be more work in the pipeline to make app pass code a lot better, consolidation was the first step.

FYI On all my test devices I see a numeric keypad but we can investigate this on more devices.

1 Like

Looks like it’s only happening when using a 3rd party keyboard, in this case Swiftkey. @moon can you chexk whether the but is there if the standard Android keyboard is being used?

Okey, I switched to default keyboard and here is how it looks on 2.18.1:

Sure I could switch to fingerprint and forget about entering PIN’s alltogether but I rather choose my mind to stretch a bit and work (remembering various numbers, hehe).

There is only 1 app for which I use fingerprint - and that is budgeting app which I use daily many times and access time with fingerprint is great, so I choose that over entering PIN.

A post was split to a new topic: Bug report 2.19.0