Bug Report - Android 2.1.11

“Rewards are back” they said.
“yay” I said.
update the app I did.
Scrolling to the rewards card or viewing timeline the app crashes it does.

Works for me on Android.

I think its an account corruption issue not migrated properly - i had weird things happen on the beta app too - have told support

Worked for me too on Android and reward are selectable now.

The older version worked fine on my Samsung phone (running Android 6).

Yesterday I got a Curve email suggesting I update. I tried it twice: after first doing the update I would either be dropped out of the app, or it would simply hang on the splash screen. Next, I uninstalled and then reinstalled, but it behaves in the same way. The app version is given as 2.1.11+20111. The use of the “back” button while within the app can drop it out of the app completely. That just happened to me. Now, when I try to get back into it, it hangs on the splash screen.

There is obviously something seriously wrong. Software this buggy shouldn’t be released. And 83 Mb in size, really? Fixing thse problems should be high priority.


(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

UPDATE: installed on another phone completely (my work phone; a newer samsung) and it works!
(old phone is a sony z3 it crashes though I have tried clearing the app cache and reinstalled many times)

However a purchase I made at lunchtime hasn’t showed up on the app on the card I used though it has hit the underlying card/acct.

New version: Bug Report - Android v2.1.12