Bug Report - Android 2.11.1 (21101)

Curve appreciate your help and feedback on bugs so they can deliver the best possible experience. Their product team is actively participating in this topic to incorporate your feedback.

When reporting a bug, please:

  • Check whether it is already reported in the list below
  • A screenshot and short description
  • Details on how we can reproduce it

I had two P2P test transaction declined for two different (valid) reasons:

1 Insufficient funds on underlying card
2 Merchant category blocked for the underlying card

But in both occasions I did get the screen telling me “Your money is on its way to [recipient name]”.


I can enter 0.01 GBP as amount, but cannot send anything under 1 GBP

1 Like

Sending money auto categorizes to General, receiving has no standard categorize

If I go into Card Information into any card in my wallet, I am unable to change:

  • Card nickname
  • Card image
  • Card currency

Or turn on the option to send email receipts.

Pressing the appropriate setting doesn’t do anything


Agree with those bugs.

Upon loading the app we’re also back to it loading with all the cards scrolled off to the right of the screen, even past the Curve Cash one, rather than the current stuff card being selected.

Both this and the previously raised issues are regressions to previous bugs that have been noted in old betas. Has some old code snuck back jn as these were previously fixed.

One other new issue I’m finding - it’s taking ages to get past the initial Curve logo splash screen in the app - normally only 1-2s, currently taking 10s+.


Timeline bug is still there , when you go to timeline and switch to month view it says “February” even though we are in September.


Card bug that @ediflyer mentioned also happens to me. It didn’t see it happen before this update though…

1 Like

Cannot change card currency which is a deal breaker as I’m going on holiday next week.


Same for me, sometimes it works, sometimes it doesnt. Hit go back to be back to card caroussel, then click on card settings again (tap it twice or 3times really fast), if it doesnt help, go back to card caroussel again.
After a few tries it worked for me.

Thanks, I tried any it worked after a few attempts. :+1:t4:

Did anyone notice an issue with creating a support ticket via the Beta app? The message doesn’t get sent and keeps failing.

1 Like

Hi, a few points about the Android beta app (v2.11.1+21101)… and sorry if they’ve appeared already:

  1. the contacts list is not refreshed, for example, after changing someone’s number or deleting them from the contacts list, except only after logging off and again
  2. any support tickets raised via the app failed to send
  3. it doesn’t make sense to send myself cash, but the entry exists, which, if selected, fails. Is it possible to exclude me from the list of contacts even though I am in my phone’s contact list?
  4. It would be good to have a summary of the proposed transaction, with an option to Confirm (perhaps together with entering passcode or fingerprint) or Cancel before committing.


I was at the grocery store today and for some reason I couldn’t pay from one of my cards. (I guess this was because of the technical issues Curve was having a little earlier today?)

I also couldn’t use “Go back in time” to move it to the correct card.

I downloaded and installed the Beta App yesterday, so maybe it has something to do with that? I also cannot change card picture or currency with this Beta App. Also sending support ticket from within the App doesn’t get sent.

Something is definitely wrong here.

There are definitely some regressions in the beta as you say (we had these with a previous beta, so not sure why they’ve resurfaced!) but it sounds like the payment issues may be related to the systems problem yesterday as you mention?

Yes, the declined transaction could be the reason of the system fault yesterday, but that doesn’t explain why I could pay with one of the other cards instead.

Anyways, below you can see which card I used to pay for the groceries: SAS MasterCard

Note: It also says I spent GBP 1,00 on the card, which is also wrong.

Using the “Go Back in Time” feature from the SAS MasterCard to the other card, this error message comes up:

Not sure why actually and the only thing I have done differently is that I upgraded the App to the beta version. But as I understand, being a betatester shouldn’t make the normal features to be unstable. (Although it might perhaps.)


Unfortunately based on previous betas that can often be the case and is one of the risks of testing. The payments issue did seem to be intermittent so I similarly had issues with some cards and then not others.

Please continue discussions in: Bug Report - Android 2.11.2 (21102)

A post was merged into an existing topic: Bug Report - Android 2.11.2 (21102)