Bug Report - Android 2.13.1 (BETA)

New beta version bug posts here…

1 Like

In the transfer screen, after selecting my card to send money to, when pressing Transfer, sometimes it fails asking me to select a card first. After a few tries, it worked

1 Like

I have passed your feedback on to the P2P team, thanks for flagging this.

Could you please let me know which device and OS you are using?

Samsung galaxy a5 2016 with LineageOS/Android 9

1 Like

Thanks @alex.1137ferreira!

1 Like

So the passcode bug from a previous version seems to have been resolved for me, but every time I try and use Curve Send I get an error saying “Something’s Gone Wrong.” - anyone else seeing this?

1 Like

The only time I received the message “Something’s Gone Wrong.” was when I (as a test) tried to send money to myself (my own mobile number).

Ah OK, thanks - that’s precisely what I was trying to do to test it :smiley: Perhaps the error could be finessed to make this clear? :wink:

1- I’m not sure if this is new but after changing the category of one transaction, only one transaction appears in the transaction history:

2 - When I open the app, I am always at the option to add a new card instead of my selected card:

3 - When I am at the Timeline screen and I click the arrows, a weird flickering happens on the letters and I am only able to go to march or last week (and the actual timeline doesn’t change):

4 - The first time I open the Send menu, there’s a big empty space on top. Goes back to normal if I switch to transfer and then go back to send:

5 -At the Insights screen, when I click on See more, I am redirected to September insights instead of October.

6 -The hamburger icon only appears on the Wallet screen. Not sure if this is a feature or bug.

7 -My final date for the curve cash retailers “bonus” is 3 months after I activated Curve but I only chose my retailers on August:

8 -I’m not being able to make or view support tickets. Always giving an error to “try again”.

9 -After I activated Biometric authentication, Curve was showing me again that ‘3 dot bubble’ to create a passcode?!? I created a passcode again and everything works fine.

10 -Here’s a screenshot of my last reported bug (happens after I click on Send at the Transfer option):


When I ask for help and support, I write a question and I receive your answer, but if I try to reply again my text introduced desapear. In its place appears your first reply once again. If I repeat the process, it continue showing me Curve first reply.

Muy device is an OnePlus 6T android 9.0

Currently I can not select any of my contacts when I want to send money to them. The contacts that are on Curve are not recognised as such, but have an invite button behind their name. This button is not working by the way.

In the Transfer menu I get the Error that my cards can not be found. See screenshot below.

Does anyone else have these issues? To me it looks like the Send & Transfer functionality has been taken ‘offline’.


After the first inicial testes a few weeks ago, with small amount, to see and test this feauture… Yesterday I had the perfect excuse to use it…
But I also came across this same problem and had to go for another alternative :roll_eyes:

Jus made 2 payments of different amounts via Curve card, to 2 different websites. Only 1 of them showed up in the app, however both are showing as pending on the underlying card. I only received the notification from 1 payment, nothing from the 2nd one.

1 Like

@JaimeFer @poeliev sorry to hear that Curve Send is not working for you. Can you please confirm device, OS and app versions so I can try to replicate it on my side and raise it with the team?

BTW, we’re releasing another version of the app in the next few days for you to test!

1 Like

It use to work fine until a couple of days ago, when all of a sudden these issues appeared.

Issues occur on my private phone which is a bit of an oldie:

Moto E4
Android 7.1.1

Sony xperia XZ (F8331)
Android 8.0.0
Curve 2.13.1

Thanks @poeliev and @JaimeFer! We’ve replicated and raised all issues.


New bug report thread - Bug Report - Android 2.13.4