Bug report Android 2.25.1

Issue: (one-sentence summary)
App launch takes 1min12sec on oneplus nord (latest android 10)
How to reproduce it:
Launch the app
Oxygen OS 10.5.3.AC01BA (Android 10)
OnePlus Nord
App version:


Same here. I often don’t wait that long but kill the app and start again which usually goes quicker for some reason.

I dont have this issue with 2.25.1 on my phone (android 9). App loads normally - ok maybe split second longer, but not noticeable.

1 Like

@bobeagle thanks for reporting.

We haven’t actually made any changed around this in 2.25.1

When you launch the app the latest data is loaded, it sounds like you’re experiencing some requests getting stuck. This could be due to many different reasons. Does dismissing the app and restarting help at all?

Hi @nicb
Actually tried again - seems using 4G network it works fine but it’s a consistent problem under WIFI.
However my same account on iPhone using the same WIFI works fine.
Do you have any optimisation in your android app specifically for WIFI? Like calling a different endpoint etc? I’m using hyperoptic broadband at home with Google DNS

TO: Curve Development - Is there a list of items anywhere which represents the changes made for this version. We seem to be getting frequent updates to the software, the latest being 2.25.1, but it’s far from clear as to what has been addressed since the previous version?

I’ll pass this on.

It looks like a couple of change logs have been skipped to recently. We usually drop them on here when we create a new beta build.

1 Like

Hi @nicb, I think there are quite a few change logs missing if you look at multiple previous Android versions.

Hi @nicb, have the change logs been published yet for the latest Android version? Some apps show this in the help section, so that you can always directly see what’s changed. Is that a possibility?

Continued in Bug Reports - Android 2.26.1

I’m still on 2.25.1 and encountered this wrong currency display bug.
Not sure if its fixed in next version (most likely not).

My Curve app is set in euro. I had 5gbp balance in curve cash and tried to pay 5.55euro.
Payment was declined due to “not enough balance” as there is no way of knowing what fx rate Curve uses in given moment and how much is 5gbp in euro.

Bug is that in Curve app it shows that I tried to pay 5.55gbp, not euro !!! Wrong currency.

When you tap on that declined transaction it shows correct amount in euro:

My second fx rate guess was correct - I paid 5.52euro and payment was sucessful and you can see its correctly shows as 5.52euro (under gbp).