Bug Report - Android v2.1.12

Change log:

  • Hotfix for rewards transactions crashing on Android devices running on Android 4, 5 & 6

We appreciate all your help and feedback on bugs so we can deliver the best possible experience. Our product team is actively participating in this topic to incorporate your feedback.

When reporting a bug, please:

  • Check whether it is already reported in the list below
  • A screenshot and short description
  • Details on how we can reproduce it
  • Which OS, device and app version you have
1 Like

Still not working, as per Bug report – Android 2.1.10

Samsung S9+ running Android 9.

I have the same problem. Logged a support ticket but it’s just gone quiet after a few initial basic troubleshooting emails.

so far so good, works on all my mobiles - previously crashing on rewards on one of them

I recommend anyone having issues to try the following:

  1. Log out of curve app and close the app
  2. find the app on your apps list (settings -> apps)
  3. Force close the app
  4. delete the cache and the app data
  5. Uninstall
  6. restart the phone
  7. download and install latest version

then if that fails please try the above on another model phone just to try and reproduce the issue


Thanks for the detailed instructions, @Gaz_zebo!

I’d say step 5 is hopefully not needed, but it probably can’t hurt.

1 Like

App still hangs as in 2.0.8 and forward. To replicate (I already have a card defined in app 2.0.8 and some minor amount drawn from my account, verified by code):

  • Install 2.1.12
  • Open app
  • Go through tutorial
  • Submit email address (again…)
  • Open the email and login to Curve through link. “Card is verified” appears, click Continue
  • Immediately after app says “Something’s gone wrong”. I have option to Resend or Add Card. I click “Resend”
  • Nothing happens any more

On every subsequent app opening the app just hangs on initial logo

BTW, the process given by @Gaz_zebo does not solve the issue for me

@Bartek do you log in with google account or email address?

@Gaz_zebo , I login with my email address.

When I log in with my email, then get the magic login link then log into curve my cards come up I sset up an app pin and thats it - no tutorial, no card is verified message…

Try another phone model - borrow someone with IOS - see if you can setup properly all the way there then when you log out of that and back into your android one see if there is any change

I’ve reset my andriod app and uninstalled/reinstalled countless times now. Same result as mentioned above on the most recent app version. I’ve also tried on an IOS device to finish the sign up. Asks me to pick a card then confirm my personal details, then says “something went wrong contact support”. I was hoping support might be able to delete my account entirely so I could try signing up again, but I’ve had no response to this.

We will be looking at this in detail tomorrow, hopefully it is something we can fix on the fly but I can’t make any promises.

1 Like

Just tried on another phone (Sony Xperia Z5c) with my current login details, same results

Definitely sounds like an account rather than app issue then - perhaps some migration got stuck previously? Fingers crossed @curve_tobias will able to get you sorted tomorrow! :crossed_fingers:

1 Like

that would only happen if you are new to curve - you should be able to sign in and see all your existing cards on any new device

Hi @Gaz_zebo, I am new to Curve, the Android app wouldn’t let me progress past card authentication (despite having charges showing on my statements). I tested on a fresh IOS device and couldn’t conclude the sign up process.

(Using Android v6 on Samsung phone).

After quitting the app ( I didn’t dare to check if all the features were functioning) it hung on re-loading and only got as far as showing the splash screen. This is one of the same bugs the previous version had.

Even when the app does load, it is slower to do so than prevous (pre-February) versions, and the Android “cycling” (rotating circle) image is displayed while the splash screen is shown.

I am having the following issues with this Android Version:

  1. Opening the app I get a “We’re having trouble migrating your account message” when I open the app, it comes and goes, I simply close the app and swipe it away, open again and it loads.
  2. Absolutely NO notifications, none of my transactions notify now, haven’t since the 2.1.11 version, transactions take a few hours to show in the timeline.
  3. Hanging on reloading just like SLC says, closing and re-opening works.

My device is an Pixel 3XL on version 9 - February Patch Level

I’ve found notifications have started to get back to normal recently - just took cash out of ATM and notified immediately on phone.


The picture of card used to show for all cards but today the Monzo card picture disappeared. Screenshot attached.