Cannot activate investor metal card

I’ve received a replacement metal investor card two weeks ago and have still not been able to activate the card.
It asks for the last four digits that I cannot provide.

Any recommendations on what I can do? I’ve tried reinstalling, tried using a different device and tried speaking to support - who have now not responded in 7 days.

I’m at a loss at what to do. Especially as I can’t use any of the services I’m paying monthly for.

Hi and welcome to the community. :raising_hand_man:t2:

Does your phone have a NFC chip? I know apps exists that (making use of the NFC chip) can read card data, so enabling you to see what are the last four digits of your card. I assume you’re on iOS (because of the tag you used), not sure if this works for iOS as well, but it should on Android devices with a NFC chip.

This is of course a work around. Support should have helped you with this already. You might try to contact them on Twitter @askcurve or give them a call on +44 (0) 20 3322 2585.

Yep, the Revolut app can read card details via NFC (on Android at least)