Curve 3DS broken on HMRC

Issue: Payment never completes after going through in-app 3D secure for HMRC payment

How to reproduce it:

  • Log in to HMRC website and select “make self assessment payment”
  • Enter Curve card details
  • When 3D secure prompt comes up, select “Use Curve app”. Countdown timer appears
  • Get notification on phone, log in to app, tap “Approve payment”
  • Timer disappears from HMRC website, but nothing more happens. I waited for several minutes.

Note:

  • If I select SMS code instead of Curve app, the payment completes fine
  • I tried on Firefox, Chrome, and Edge. None worked
  • I have Curve fronted switched on. The underlying card itself must be fine or the SMS path wouldn’t work either.

OS: Android 10 on phone, using HMRC website on Windows 10 with Firefox, Chrome, and Edge

Device: Galaxy S10

App version: 2.35.2

Screenshot:
After completing 3D secure, website just gets stuck on this:

2 Likes

Update: today I tried using email as the 3DS method, and it also failed. After I clicked the “send me an email” button, an error message briefly appeared (for less than a second) then I was redirected back to an HMRC page saying my card details were wrong. I auto filled the card details using a password manager, so I can’t have mistyped them.

I then repeated the payment (same amount, same underlying card) with SMS as the 3DS method, and it worked fine.

Seems SMS is the only method that works for me on HMRC :frowning:

I had similar issue once. I can’t remmeber what merchant it was, but only sms worked ( the app confirmation was rejected)

This seems to have been fixed now :slight_smile: made a tax payment this morning and in-app verification worked fine. Don’t know if this was a fix on Curve’s side or HMRC’s, but great to have it resolved