Decline with reason: "looks like you've reached your card limit"

Tried to top-up monese via Curve (from debit card) as usual and got hit with decline from Curve “It looks like you’ve reached your card limit. Please contact our support team”.

I’m nowhere near my limits. Anyone else have experienced this decline reason without actually reaching limits?

Sure, I’m contacting support. Lets see how fast I will get reply.

Yes, happened to my wife a week or two ago. :scream: It just didn’t work with that specific retailer but another transaction in another shop few minutes later worked OK. :hot_face: It didn’t show up again since then… :cowboy_hat_face:

My suspicion is the error reason was incorrect, in fact the retailer (or rather his payment terminal/provider) just wasn’t “compatible” with Curve (but it was some usual retailer selling paper, pen and other similar stuff if I recall correctly). :thinking:

Curve marks top-ups as “business services”.
My suspicion is that there is some kind of internal limit for such transactions.

I made 1 POS purchase with Curve after decline - worked fine.

p.s. Someone remind me - should you receive automatic response from support right after e-mailing that e-mail is received or not? (cant remember). I did not receive anything.

For monese top ups you need Fronted enabled (fee incurred)

Was it recently introduced then? Previously it was fine (when using underlaying debit card).

Only if you use a credit card as funding source so would not apply in this case as a debit card was used.

Got reply from support.
They said decline was due to “timeout” and that they aware of “display issue” (wrong decline reason).

Update: Just tested it again with new transaction and it was declined immediately. So real reason must be something else :confused:

1 Like

Got another reply from support. Now they said that bank (underlaying card issuer) sent them code “do not honour” and thats why it was declined for Monese top-up. They suggested to contact underlaying card issuer, which is Revolut in my case.

It’s a bit weird - becouse all other purchases works with this Revolut card thru Curve. And it worked before for monese top-up via Curve. Only thing thats changed from revolut’s side - they switched clients (me also) from GB to LT. So if earlier top-up from my bank to Revolut appeared as transaction to GB, now its transaction to LT. Maybe thats the reason something got wrong (as revolut card was added to curve long ago while it was still under GB, not LT).

Also to test “fronted must be ON” suggestion from Lucas in some posts above I switched it ON and tried top-up. Transaction was still declined.

Will try to contact revolut’s support now.

Have your tried using the Revolut Card directly?

If it works, then it means that is not likely to be Revolut blocking the transaction.

Yes, I tried. And it worked.

p.s. If its blocked by revolut it should show decline also in revolut app? There is nothing there.

Really strange, my guess was that maybe Revolut declines now all monese transactions, but if you can use Monese directly with Revolut, then that’s not the case.

Looks like some other Curve users also having this for various underlaying cards. I found for example this post somewhere in other site - Italian forum (google translated).

Screenshot below:

p.s. Answer he/her get from support is exactly same which I also get.

I had the same thing when I was buying fuel from Asia. I had to contact my underlying card. As that card was blocked. Nothing to do with Curve.

Happened again yesterday with PPL (after very long period without this error appearing). :frowning: Wasn’t able to pay with my nor my wife’s card with the error “Declined as you’ve reached your spending limit”. Of course the limit was not reached and there was sufficient balance on the underlying card… :thinking: Payment with other card was OK. Other later payments with Curve card and the same underlying card were OK as well. :money_mouth_face:

It might have been problem with the underlying card :man_shrugging:, but at least the text of the error is incorrect/misleading. :woozy_face:

Fortunately, it seems to be only pretty occasional bug… :bug: