Display issue with Smart Rules when locale is not English

Issue: Created Smart Rule is displayed incorrectly

How to reproduce it: Set-up the main currency in EUR and enter the smart rule e.g. with amount of 55EUR - see the attached screenshot

OS: iOS 15.4.1

Device: iPhone 12

App version: 3.41.0 (27430)

Screenshot:

My local decimal delimiter is “,”, not “.” - it is common in my language and region (Slovak) to delimit decimals by comma. Also, I cannot enter anything other than integer in the Smart Rule configuration dialogue because comma is not accepted as delimiter - so I suppose the display issue is related to the locale settings.

This has been resolved in app version 3.49.0