Error placing order

I’m trying to sign up for a new card but the iOS app just throws back an error every time.

‘Error placing order
Something went wrong, please check your connection and try again’

It’s definitely not my connection - I’ve tried multiple WiFi and 4G signals, even a hotspot from another phone. Also tried uninstalling app and reinstalling.

Customer service seems very poor, took 3 weeks to respond and I was told to reinstall (equivalent of turn off and on again). Been waiting for 3 days since this initial reply.

Has anyone else signed up since the Amex issues started? If I’m the only one with this issue then fair enough I’ll wait for support reply but seems like a bug to me

Had his happen mutiple times when trying to sign-up my partner. Kept retrying and it suddenly worked. I persevered, but I’m not sure my partner would have.

Ok thanks! Will keep trying… anything different at all when it started working? iOS update or anything like that?

Nothing different at all… just a big dose of patience :-/

I’m having the same problem trying to order a card on iOS. Any sign of a fix for this? Or is there anyway to order a card online?