Go back in time issue

Hi, I have experimented some technical issue to use the GBiT process with my yeste4day purchases. It doesn’t run and app is closing itself with technical reason.
The process was running few days ago and I’m trying with small transactions, my cards are activated etc…
I also tried to put off my phone, reinstalled app etc…
Any reason to that please ?
Many Thanks

1 Like

I have the same problem

Yes, I can’t go back in time at all anymore. Extremely annoying and the problem have been persistant for days now. Please fix this asap.

1 Like

I have the same problem too and I am not alone in the Czech Republic.

The same problem with my GBiTs - doesn’t work at all.

For me an update of the app to 2.23.1 (Android) solved the issue. But when I used GbiT the result was a little peculiar. I now have a pending credit transaction on my original card, but the original transaction was also taken from that account again (see screenshot). From the destination card the money was also taken.

Hi, issue seems to be solved with the latest app update. Try to check after download.

1 Like


Have you found a solution for this yet? I have the same problem…


There have been some changes, but unfortunately it’s not solved yet.
The 2nd charge on the original card has disappeared, but the first charge is still there, as is the charge on the destination card. So at the moment I am still out of pocket twice the amount that I should have been. I will give it another couple of days and if not solved by then I will contact the ‘bank’ of the underlying card of the original transaction.
I hope this is not the standard way the ‘new’ GbiT works :confused:

My guess would be that it has to do with the (limited) information provided by Curve to MCO about the “removal” of the original payment amount and it could well be that MCO blocks the same amount again to make sure it won’t fail. That could mean that once the GBIT is all processed, MCO frees up the new blocked amount again. Or, at least I hope so.
I’d appreciate though if Curve could take a look at this issue…

Hi, issue is now full solved as the GBIT is running and transactions went back.

hope everything will be solved for you soon.
Could you please update us if there is anything new to it? I also use the MCO Visa Card and probably just will wait until everything is resolved before I use GBIT on it. Many thanks.

By now I am quite certain my issue will not resolve itself. Currently I am on a trip, but when I return I will contact MCO Customer support.

My guess is that you want to use the MCO VISA card as the ‘destination’, I don’t see much problems in doing so. My problem arose when I used GbiT to move a transaction away from MCO to Revolut.

1 Like

Hey guys, we released a new version of the app recently so if you’re still on the old version you might run into some problems with this. If you’re on the new version and are still experiencing issues when attempting to GBIT please reach out to our support team so they can investigate further!

I have the newest version and every GBiT transaction I have done makes a cover reservation to the card I transferred the transaction from. Currently I have 200€ worth of locked funds because of this. I have contacted support via the app but no one has answered me. It has been three days now. Really disappointed in the situation.

@Chief @Bumshak

I promised an update. Contacted MCO support on Wednesday evening, first line responded within an hour. My question was forwarded to the relevant department and just received an answer that is not solving my issue.

Just as @Inertia in the post above mine is reporting, Curve made a ‘cover’ reservation on the card I moved the transaction from (MCO VISA in my case) for the same amount (-€38,66) than the GBiT transaction. Now I was -€77,32 (2 * €38,66) on this transaction.
This cover transaction was reversed within a day, but now MCO thinks that by refunding/reversing this cover transaction they completed their part of the GBiT transaction. So now I am still -€38,66 on my MCO balance, because the original transaction was not reversed/refunded.
I just talked to first line support of MCO again (tried to do some more explaining) and they forwarded my question to the relevant department again.


Decided to download my card transaction history from the MCO app for a thorough analysis by myself. And the situation turns out to be not that grim. My total balance is correct, however my original transaction is still present (including the received cryptoback/cashback), but there is a separate refund transaction (not taking away the received cryptoback/cashback!). So though this definitely is not disadvantageous to me, this is in my opinion definitely not the way a refund in the GBiT should be processed.

@Hannah Looks like MCO is not able to process the data that Curve is sending them in the new GBiT process (after Curve left Wirecard) in a correct manner. The refund transaction can not be matched to the original transaction.
If MCO is not able to do so, chance is there that other ‘banks’ will also not be able to do so.


Thanks! This is really useful and seems to confirm my observations.