🚨 Important iOS status update

:rotating_light: Important iOS status update

Yesterday, some of users were affected by a bug which prevented launching or logging into the Curve app.

We’re sorry for any disruption caused and the engineers have now deployed a fix.

Please follow the steps below:

  • First, please make sure to upgrade to the latest version of the Curve app (3.81.1)
  • If you continue to experience this issue on the latest version of the Curve app then uninstall and reinstall the app to apply the fix. :wrench:

Still having trouble? Drop an email to support@imaginecurve.com with a description of the steps you’ve taken so that they can dig into this for you!

1 Like

I’m still having a problem. I’m a new user. It wouldn’t let me add a new card to pay for a new plan. Then it only gave me the metal options and wouldn’t change screen. After reinstalling the app. I log in and it tells me it cant retrieve my account info. Then, i close the app and reopen it and it brings me to a blank page with the title “your curve card”. …… idk what to do

1 Like

Hello @Ritafrancis,

Thanks for reaching us here.
I just shared your issue with our CX team. I hope that very soon someone will get in touch with you and will resolve your issue.



Welcome back Greg, thanks for helping out forum users.

1 Like

hey @Ritafrancis , I reached you out in DM.


I am having issues too, it does not allow me to log in, I can received the mobile verification code and the email code and after just ask for a pass code that I do not know what it is. when trying to have a password rese it say that i can not retrieve my details. very odd.

Have uninstalled and reinstalled the app few times and the issue maintain

Typical IT response - Turn it off and on again and/or reinstall the app.

I had an issue this afternoon, the app (v3.82.0) reported an error then prompted me with the first-time setup process when I reopened it. That process would not accept my passcode. I deleted and reinstalled the app with no success. I tried again 15 minutes later and the app just worked.