LoungeKey is not activated


anyone got the same error that he cant use his metal investor. card on LoungeKey?

Error: “Please enter a valid payment card number associated with LoungeKey.”


Once I received my Metal Card, I downloaded the LoungeKey app and just created a new profile (as I hadn’t had one before) but I was then charged $1.00 / £0.81 converted to activate, after that it now works fine.

Bit of a silly question to ask and no offence intended to you whatsoever, but was the Card number you inputted, correct?

If the error continues, I would contact Curve Customer Services via the app.

Account > Profile > Help > Still need help? Contact us


yeah, i copied the card details from the app, evertything is correct. I already contacted the Curve Support.

I think Curve just forgot to enable LoungeKey on this Key.


Well all being well they can help you out then, I think it should be enabled automatically as it’s needed to access the airport lounges in person (hence the bigger chip maybe? - or I believe it’s to be swiped by the mag stripe, otherwise I’m honestly not too sure in terms of that!)

But good luck with getting your issue fixed!

1 Like

I am assuming the card number is not being accepted even after following the directions on the Curve support site?
" * Sign up online. Go to www.loungekey.com/curve and create a web profile using your Curve Metal card number. If your card says “Business” on the back, go instead to www.loungekey.com/curvebusiness and create a web profile. Then, you’ll be able to login to the LoungeKey™ app"

I that’s still not working, it might be an issue with your card and the recent transition away from Wirecard, in which case just wait for Curve in-app support to get back to you. Also I too was charged $1 (£0.81) when I signed up (it’s a card check that doesn’t appear to get refunded but for one-dolla am not going to complain…


it worked fine before i got my replacement card.
I wait for Curve to answer my ticket.

Did you get any answer? Before my card was replaced with a German one it worked for me as well, but now I can’t register my card…