Make timeline fix a priority

The timeline has been broken since the beginning of 2020:

  • Refunds shown incorrectly
  • AUTHs shown as not been expired, even after months
  • wrong transactions
  • charges disappearing + only refunds shown as credits

The bugs has been addressed many many times in various threads but so far no fix.
Can we please make it a priority to get it fixed? Having a correct statement / timeline should be a core element for any fintech and should not be broken for almost a year now.

To give you a new example.
According to the timeline I received today a refund of 64,881.00 USD (yes, 64k$)
image

Push notification showed correct (full) refund of 648.81$ and email copy also shows 0€ charge & 648.81$ refund:
image

As of right now the only way to receive accurate information for transactions + refunds are the email receipts, the app timeline is just full with wrong information.

Agree - @nicb do you know where this is on the list?

1 Like

@Lucas thanks for reporting. Do the transactions show up correctly in the Wallet & Insights?

I can’t believe they’re making it out to be like a one-time, personal issue. This has been ongoing for ages and is undeniably endemic across multiple transactions, iOS/Android, seemingly comes and goes. Kudos to @Lucas for finding the energy and patience to post this.

@nicb I tried a hard reset of the app (=delete cache + app data )to see if it fixes at least the 64k$ bug. But since then I’m unable to login to my account anymore, always asks me to enter my passcode, even after passcode reset from the Curve team, it still says unknown error.

I already receive push notifications, but cant access anything else.

So I cant check if wallet & insights are shown correctly, but the timeline has been wrong since Curve introduted the new (current) refunds aka hiding original charge and only showing refunded amount for partial refunds.

Since then I’ve had expired AUTHs from many months + years still shown as pending or even as charged even thou the funds were never captured and the AUTHs expired.

Same problem here, my passcode doesn’t work after reset but I’m still receiving messages

Version 2.43.1 fixed that for me. We’re at 2.45.0 on Android already, so that bug shouldn’t be there anymore.

For me it got fixed yesterday, also i don’t think it was bug that was fixed with update since I had updated app to 2.45.0 and it still didn’t work, yesterday it just randomly started working

Whilst the refunds have been massively improved in terms of speed and visibility, I have noticed that they are not deducted in the timeline filters (unless I’m missing an option :man_shrugging:)

For example, if I want to see how much I have spent this month on my groceries spend, the total does not reflect any refunds and I have to manually reduce these from the total which is a bit annoying especially if there are loads.

1 Like

I have the same problem. The timeline shows 18.000€ in transactions, but I spend 180€ in Points, not 18.000€ :sweat_smile:. Version 3.6.1

I posted here too (i didn’t find this thread when searching): Is this a bug - received part refund, original transaction is gone, can't go back in time

In my case even a small par-trefiund (£20 refunded of a £300 transaction) still wiped the original transaction and then “go back in time” ability was gone as well. Also messes up accounting and balances as other have said here.

3 Likes

@nicb just flagging some ongoing issues here to make sure your team are aware :+1:

yes, still problems for me, refunded transactions still shown as charge but no refund, partial refunds displayed wrong, only refunds shown as +x€ but no -x€ for the original transaction,…

2 Likes

I think I have the biggest bug of all, already contacted support about it…

My timeline will not load, my app, won’t load balances for cards or anything. It’s just blank. Only thing I can do is chat and switch my card.

1 Like

Could we PLEASE get the timeline finally fixed? We’re waiting since the beginning of 2020, thats 18months now!
Still transactions shown as pending even thou they are finalized.
Still wrong amounts shown as charged.
Still some refunds are not shown at all.
Still wrong refunded amounts shown.
Still transactions shown as charged even thou they were fully refunded

4 Likes

This starting to be boring, just made a purchase at fuel pump yesterday of 10€ and a preauth of 100€ was requested on curve.
Actually i have in the timeline on curve a pending transaction of 110€ (preauth+purchase) that is a nosense.
Probably is going to be changed like first post with the preauth disappearing and the payd amount shown as credit…
Looking at the timeline:
On another day i have just the debited amount with no preauth in the timeline
On another transaction the debit amount showed as credit (like first post) and still no preauth movement
On another day i have 5 Declined transactions that in real all got success (probably due to the fact that backup card was used for the preauth) 3 with the amount of what was payd, 2 with the amount of the preauth, in all of these there was a preauth of 101€ and than just a debited amount of few euros.

Basically whenever there is a preauth and then a (partial) refund of the preauthorization we have random things happening in the timeline.

I agree - Especially for Go Back In Time transactions.

With a Virgin Credit card, you can only earn points up to your credit limit each calendar month.

This means I care a lot about being able to accurately see how much has been spent on the card in a given time period/month.

With Go Back In Time transactions, the amount that was charged to the New/Replacement card isn’t treated as a new spend and it isn’t added to that card’s ‘Total Spent’ statistic. Nor is the amount removed from the Original card’s ‘Total Spent’ statistic.

For e.g.

I spend £2000 on July 31st on Card A

On August 5th I do Go Back In Time to move this transaction to Card B

Ideally, the £2000 spend would be removed from Card A’s Total Spent statistic for July once it was refunded, and added to Card B’s Total Spent statistic for August.

This doesn’t seem to happen :frowning_face:

I wish this was by default or at least an option we could toggle.

1 Like