My Money Balances doesn’t load balances!

Issue: Balances under My Money feature doesn’t integrate with Nationwide and Metro Bank (two I tried) and pull balances.

How to reproduce it: try to add Nationwide Building society and Metro Bank in the U.K. Gets a message successfully loaded but never completed!! Reported this issue a month ago and never got fixed!

OS: iOS 14.6

Device: iPhone 12 Pro

App version: 3.6.20 (13709)

Screenshot:

My Nationwide balance works, my Santander one does not

That’s strange. What build version you got?

The latest - 3.6.20

I got the same version too!

The error doesn’t help either

Have you tried adding your bank with a 4G connection? Does it give you the same error? :thinking:

Though it’s pure internet either way, isolated that cause too! :smile:

I’ve had a similar issue with Virgin Money (Yorkshire/Clydesdale Bank). Shows a balance of zero, as does the Amazon Credit card.
I gave up with the functionality as it never showed a balance.

Looks like it’s a half cooked solution which they are struggling to fix!