Push notification sound missing?

Is it just me or Curve’s push notifications (for example for purchases) does not have sound ?
Currently I mostly use underlaying card which also sents notifications so I do get push notification sound, but its from underlaying card app, not Curve app.

Can Curve make optional feature to add notification sound, becouse otherwise push notifications are kind of useless.

1 Like


They have a Normal notification sound my iPhone XS Max, running iOS 13.1…

I’m on Android.

1 Like

I get a normal notification sound on my OnePlus 6…

Normal notification sound here too on Xiaomi Mi 9

Hey @moon you should be able to get sound notifications when using the app.

If you go to your phone settings then go to ‘Manage Apps’ and locate the Curve app, if you then select the ‘Notifications’ option you should have the option to go through to the 'General Settings’

Once here you’ll have the option to toggle on ‘Sound Notifications’ and select a sound. In order to hear the sounds your phone will also need to be on loud at the time of making transactions.

Let me know how you get on!

Still using android 6.0.1. There is more new version out for my phone, but I know I will loose certain cool features specific on my phone, so I dont update.

This is how it looks on my phone for Curve app (same settings for Revolut and it works for Revolut app):

Strangely enough there is sound missing also on 1 other banking app on my phone, so only banking app which gaves me proper push notification sound is Revolut.
Very weird.
I guess I have to live with that (i know I can update my phone to more recent version of android and probably issue will get fixed, but I dont want to do that, becouse I know I will loose certain awesome features on my phone which I use every day).

Edit: just found 1 promising option on my phone. Will see if its fixes this. Will let you know.

I think I found what was causing this (I hope… will test tommorow).

To be able to hear push notification sound app needs to have “Storage” permission. My Revolut app did have this permission, but Curve and other banking apps had not.

Fingers crossed it will work. Will keep you informed.

Update: Nope, adding “storage” permission did not fix anything. Still no sound. Very weird issue. From all banking apps I have, there is sound only in Revolut app. :zipper_mouth_face: