Saving a new card nickname doesn't work

I’m using Curve on iOS 12.1 (iPhone 7) and when I tap “Save” to save a new card nickname nothing happens. I’ve tried restarting the app, but no change in behaviour.

All information connected to your Curve card, account, and transactions is considered personal information that we cannot discuss on the forum. There are various reasons for why a decline occurred and our Customer Support team have the expertise to pinpoint what happened and help you out.

What sometimes helps is the classic “turn it off and turn it on again” strategy that can be translated into “delete the app and reinstall it” :smiley:

It wasn’t a card decline, it was a failure to save a new name for an existing card in the app. I might try reinstalling the app at some point.

Ah, I see - My apologies for the confusion!

From the About the Bug Report post:

Yes, I’ve done all that above too except the screenshot as I am not about to post details of my card online :slight_smile:

I can’t find the app version in the app itself. Is it there? It’s the latest version though.

No, of course not - the details would have to be blurred! The latest version is 2.8.6.

Thank you for letting us know the :bug: has been report in our system.

1 Like

Have you tried logging to your curve app on a different device perhaps?

Just downloaded the app for my iPad and got the same problem there. Tapping “Save” does nothing.

Oh, looks like it’s a backend problem! I’m having the same! I’m sure the tech guys will be onto it as we speak

Me also I’ve just tried to see if I could change it and I can’t change the image either.

Both these issues (unable to change name and unable to change card image) are certainly known bugs on the beta version, it used to work fine in the main app.

I’m not aware that I am on a beta app and it doesn’t work for me. I can change the card image though.

Interesting - iOS or Android? I’m on Android and can’t change either. Unfortunately the bug threads are a bit strewn throughout the forums here but definitely have seen other mention both!

iOS here. I noticed it a few weeks ago.

Our iOS engineers are currently working on a fix for this bug :slight_smile:

1 Like

Hopefully the Android ones are too!!

Android users: the issue will be solved to logging out and in again :smiley:

Afraid not - can’t change card name or image even after logging out and in.

Try clearing all data for the app, then logging in again.

OK have now tried that - still no change, won’t let me edit name or card image for any of them.