Stuck in login loop

I’m stuck in a login loop and i have not been able to get the support guys to solve it and email responses take days. I try to login to the curve app…i input my email address…i get the email with the magic button…i press the magic button (all this done on my samsung note 9)…i get redirected back to the same “enter the email address…” part of the app. and so it goes around - I’ve delteed the app and re-installed. I’ve cleared the cache. I’ve rebooted my phone. Anyone had the same issue and knows how to resolve? I’m basically left with no alternative but to ditch my curve card…which i have totally loved up to now…

Ehi @Stormycat, welcome to the community!
What version do you use the app? Stable or Beta?

Try to expose an app update and see if you solve the problem.


It sounds like you’ve done everything a techie would do. One thing you might not have tried is doing all of these things on a specific order.
Go into app info.
Force stop
Delete data (not just cache, big difference)
Uninstall the app
THEN Reboot your phone and re-install
I’m just grabbing at straws here to try and help.
The other option is to reinstall a previous .APK that was working. You may have one on your Samsung backup/cloud depending on your default settings.
I know I’m anal about it, but I used to save my last three versions just in case of a bad update.
Good luck!!!

Thanks buddy - i really appreciate the straw grabbing. Had a go at all that but no joy.

What is super interesting (err…probably) is that i just installed the curve app on an old iphone…and it all worked just fine (login, magic button etc)…so that means its a problem with my Samsung Note (not at Curve / my account) you think?..

Hey @Stormycat Please get in touch with our support team at about the magic links not working for you correctly. Our team will be able to review the bug you’re experiencing.

1 Like

Hey, not sure if eventually got an answer to this problem, but I’ve just had the same happen on my Samsung S10. Support weren’t able to provide an answer, but I managed to sort it. I changed my default Internet browser to the Samsung Internet app and signed into my emails via the webpage rather than my email app and then the magic link worked as it should. I think the fact that they do not allow android users to sign in with a password is crazy especially as they do for IOS users.

Hi, i can confirm that Is a browser issue.
I have been using Firefox and i had your same problem with the login.
Solved by activating Chrome as default browser, and then clicked the magic link. After that i clicked the “open curve” link into the browser and the redirect to the app worked like before.