Transactions all being processed in A$ instead of GBP on Virgin Money MasterCard

Issue: (one-sentence summary) Transactions all being processed in A$ instead of GBP

How to reproduce it: Make a transaction

OS: ios 15.5

Device: iPhone 12 Pro Max

App version: 3.41.0 (27339)

Screenshot:

Did you checked linked card default currency? Maybe it is set to A$ ? :eyes:

1 Like

Hi Moon,

I’ve looked through all the Curve app settings but I can’t see a setting for default currency. Can you tell me where to look?

If you mean the underlying credit card, this is a Virgin Atlantic Mastercard, which was issued in the UK years ago and has always been GBP. If I make a charge directly with the card, it show up in GBP.

It only comes up in A$ if I make a charge using my Curve Card.

With many thanks

Do I need to downgrade the app, from beta TestFlight to an earlier version?

@philip Wallet → Settings (that spin thingy) → there you will see default card currency set for underlying card.

Hi Moon,

Yes, it was set to AUD.

When I set it back to GBP, I got the message,

Different currency

Please note the currency you’ve chosen (GBP) is different than the one detected for this card (AUD).

Do you think the app will try and change it back to AUD again?

I’ve checked my other cards but they are all set to GBP.

All the best

@philip: App should not change back that setting by itself.

Yes, it is very strange.

I think that it happened after I last updated the app.

I am on TestFlight for testing the beta versions on Curve. I am currently on version 3.410(27339). Is it possible for you to check when I installed it?

TestFlight on my iPhone says that the version expires in 86 days. I think that they are valid for 90 days, which would mean it was installed 4 days ago, which would be 6th May and the problem started on the 7th May.

All the best

As this is a user community we are not able to check this for you. But as can be seen here:

https://community.curve.com/t/curve-3-41-0-27339-ios-beta/41342?u=poeliev

this iOS beta version indeed became available on the 6th of may.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.