Upgraded to Curve Metal, Still don't have access to any of the features

Hello, over a week ago I upgraded to Curve Metal and I still cannot access any of the features, my account is quite clearly glitched and I have yet to receive a response from customer support other than “have you tried reinstalling the app” in which I responded that I had and then received no response after that.

Here is my account, showing clearly I have activated my curve metal card:

I initially showed a full comprehensive set of screenshots but new users apparently cannot post more than one piece of media? Why? So here is a list of the issues I am experiencing:

  • When I go into manage my plan I just get a notification oops something went wrong
  • When I go to upgrade my plan it gives me the option to upgrade to Curve Black or Metal despite already activating my new metal card?
  • Curve gives me the option to get 1% cb on retailers for a free 90 days trial (doesn’t actually work) and this is already a feature I paid for
  • When I go to select retailers, it prompts me to upgrade to Curve Black or Metal

I am having the same problem after upgrading the second time, I am not getting the 1% cb on the retailer feature.

Same issue when I upgraded to Metal roughly same time as you. They’ve charged my credit card and I have a metal card but none of the features. Support initially asked for a screenshot from my credit card to show I’d paid but since then have ignored me via app and Twitter. Considering asking my credit card provider to do a charge back.

Similar here, however I can’t pick my retailers and I’m limited to the free plan limits of go back in time (except it worked on the 1st and stopped working again on the 2nd).

My insurance and lounge is active but everything else is broken.

This has been going on for just over a month. Support refunded me my £150 whilst they look into it but warned it might not be a quick fix. They asked me not to select upgrade as it would trigger a new card.

This looks very similar to the issue I have - except I have also been charged by curve multiple times for the privilege - did you manage to resolve this issue?